schedulling akses client ke yahoo messenger……..

pada intinya cara ini dimaksudkan untuk membatasi jam chating dengan menggunakan yahoo mesenger yang diinstall dan yang menggunakan web yahoo messenger. Yang dilakukan adalah dengan memblock port-port yang dipakai (dari hasil-nya didapat bahwa “hanya” dengan port-port ini sudah membuat client tidak bisa chating baik menggunakan ym yang diinstall atau dengan web yahoo messenger) sedangkan untuk cara login yang lain semisal lewat meebo atau lain2 diambil langkah ekstrim dengan memblock website-nya berdasarkan ip-nya (didapat dari hasil ping ) dan lagi-lagi ini dilakukan di mikrotik dengan menggunakan winbox.exe. Adapun port2 yang diblock adalah :
  1. port tcp : 5100, 1677, 5050-5051, 5000-5010, 20-21, 23, 8001, 25, 27, 119, 37.
  2. port udp : 8001
jika dibuat kebijakan yang sama dimana semuanya dibatasi jam chating termasuk admin (adalah hil yang mustahal….pinjem kata2 alm.asmuni ) maka tinggal membuat filter rule di firewall (dengan chain: forward) lalu diberi comment yang sama. Comment ini nantinya digunakan sebagai tag pada script untuk meng-enable atau disable filter rule-nya. setelah script dibuat (ada 2 buah script, satu enable rule dan satunya lagi disable rule) tinggal kita buat schedullernya disesuaikan dengan kebutuhannya.

contoh scriptnya :
1. script filter rule :

/ip firewall filter
add action=drop chain=forward comment=ym disabled=no dst-port=5000-5010 protocol=tcp
add action=drop chain=forward comment=ym disabled=no dst-port=20-21 protocol=tcp
add action=drop chain=forward comment=ym disabled=no dst-port=23 protocol=tcp
add action=drop chain=forward comment=ym disabled=no dst-port=8001 protocol=
tcp
add action=drop chain=forward comment=ym disabled=no dst-port=8001 protocol=
udp
add action=drop chain=forward comment=ym disabled=no dst-port=25 protocol=tcp
add action=drop chain=forward comment=ym disabled=no dst-port=27 protocol=tcp
add action=drop chain=forward comment=ym disabled=no dst-port=119 protocol=tcp
add action=drop chain=forward comment=ym disabled=no dst-port=37 protocol=tcp
add action=drop chain=forward comment=”” disabled=no dst-address=\
208.81.191.110 src-address-list=LAN

yang terakhir itu untuk block meebo.
2. enable/disable script

/system script
add name=ym-on policy=ftp,reboot,read,write,policy,test,winbox,password,sniff \
source=”/ip firewall filter disable [find comment=ym]”
add name=ym-off policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
“/ip firewall filter enable [find comment=ym]”

3. scheduller script

/system scheduler
add comment=”” disabled=no interval=1d name=sch-ym-on on-event=ym-on \
start-date=oct/22/2008 start-time=10:00:00
add comment=”” disabled=no interval=1d name=sch-ym-off on-event=ym-off \
start-date=oct/22/2008 start-time=14:00:00

contoh scheduller diatas klien bisa chating mulai jam 10.00 dan kemudian dimatikan jam 14.00.

Untuk kebijakan lain, semisal hanya ip dari komputer admin atau ada sekumpulan ip client yang bisa online selalu maka harus dibuatkan address-list yang memuat ip-ip yang bebas chating. Address list ini tinggal dimasukan ke dalam src-address-list di rule-rule diatas dan jangan pula menambahkan tanda seru (!) disamping src-address-list. klo tidak diberi tanda (!) maka hanya ip yang masuk didalam address list yang akan diblock.

selamat mencoba…

Iklan

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout /  Ubah )

Foto Google+

You are commenting using your Google+ account. Logout /  Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout /  Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout /  Ubah )

Connecting to %s